Mapea tus teclas con xmodmap y setxkbmap

No sé ustedes, pero la verdad es que la tecla Caps Lock es probablemente la tecla más inútil del teclado, no sólo inútil, sino que además es grande y está en una buena posición. ¿Se han preguntado alguna vez si hay forma de aprovecharla en algo mejor?.

La verdad es que sí hay formas —y hartas— pero en este artículo me referiré a dos: xmodmap y setxkbmap. Ambas parte de los paquetes de Xorg.

Ambas soluciones sólo funcionan en la X, si quieres aplicar estos cambios en una tty, tienes que hacer algo similar a lo que explican en el wiki de Arch Linux sobre el KEYMAP.

setxkbmap (o directamente en tu xorg.conf)

Esta es quizá la forma más simple si quieres un cambio bastante común: utilizar el Caps Lock como Control; para ello basta ejecutar:

Sigue leyendo

Anuncios

Problema ATI 9.4 en Jaunty, instalación ATI 9.3 en Intrepid + arreglo suspender/hibernar en Dell Inspiron 1501 (V.8)

ATI Logo

Antes de comenzar, y lamento ser aguafiestas, es que para los que gozamos de un Inspiron 1501 con una ATI Radeon Xpress o varias otras tarjetas de video compatibles con DX9, ATI nos ha tirado al olvido. Así es, la compañía optó por mover estos drivers a lo que se conoce como legacy, es decir, drivers que ya no serán actualizados para poder enfocarse mejor en las nuevas tecnologías. Así es como que el último driver compatible es el Catalyst 9.3 (al momento de escrbir esto van en la 9.5). Me parece lamentable puesto que mi equipo tiene 2 años de antigüedad, no creo que sea tan viejo como para que sus drivers dejen de actualizarse. Como sea, eso no es lo peor de todo…

Lo peor de todo es que Canonical está haciendo lo mismo que tanto nos molesta de Microsoft – forzarnos a actualizar el hardware -. Esto como es de esperarse se debe a problemas de dependencias de algunos paquetes. La situación es la siguiente:

  • Jaunty viene con…
    • xorg-driver-fglrx 9.4 (primer problema; no es compatible con nuestra tarjeta de video) y,
    • xserver-common 1.6

El segundo problema aparece cuando nos damos cuenta que el driver anterior de ATI (fglrx 9.3) requiere una versión más vieja de xserver, específicamente la 1.5.x Esto nos lleva al triste desenlace que no hay manera de instalar el driver privativo en Ubuntu 9.04. Intenté instalar la versión anterior (haciendo un downgrade de xserver 1.6 al 1.5.x) desde los repositorios de Intrepid y luego instalar el fglrx, pero no me fue bien. Al final opté por quedarme con Intrepid y esperar hasta que haya alguna solución.

Bueno, así que vamos a recordar la instalación de los 9.3 en nuestro good ol’ Intrepid…

Sigue leyendo sobre como instalar los drivers privativos…